Blank lines disappearing

Don't know how to do something? Having issues running the program? Please post here.

Blank lines disappearing

Unread postby sandie » Wed Jun 14, 2017 11:02 am

Hi,

I am working on a file whose subtitles were all ready to be filled in by my translation. Some had content already and some were empty from the beginning and after opening the file a few times, the blank lines have disappeared. Does anyone know how I could recover them?

Many thanks for any help.
sandie
Comic Sans MS
Comic Sans MS
 
Posts: 1
Joined: Wed Jun 14, 2017 10:52 am

Re: Blank lines disappearing

Unread postby jfs » Tue Jun 20, 2017 11:53 am

This depends on the file format you use.

If you save the file in SRT format, or one of many other formats that don't support overlapping subtitles, Aegisub will make a "recombine" pass across the subtitles to make sure there are no overlapping subtitles. This has the side-effect of removing empty subtitles.

The empty but timed lines are probably entirely gone, you need to restore from an earlier version of the file to get them back.

My best suggestion for avoiding this is to use the ASS format when working on subtitles in Aegisub, and only export to SRT (or whatever) when your work is complete.
Do not PM me asking for help with Aegisub, Automation, karaoke or anything like that, I won't reply.
Ask your questions in the public forums. Use the Search function, somebody probably asked the same question before.
All rights reserved to call you insults if you ask poorly thought out or redundant questions.
Experimenting is free and is a great way to learn things.
User avatar
jfs
Developer
 
Posts: 2994
Joined: Mon Dec 19, 2005 8:18 pm
Location: Denmark


Return to Aegisub Help

Who is online

Users browsing this forum: No registered users and 0 guests