All Hotkeys/Shortcuts unavailable after Saving

Don't know how to do something? Having issues running the program? Please post here.

All Hotkeys/Shortcuts unavailable after Saving

Unread postby zcc911 » Sat Apr 29, 2017 10:48 am

Hi,

The problem which was described in the topic's title is a long-term issue that annoying me for months. Once I clicked the "Save" button or press "Ctrl+S", then all those hotkeys/shortcuts("a", "s", "d", "f", "g", etc) became invalid, and the working efficiency drops since I have to use mouse to take over the job... So I have to restart the Aegisub for convenience, which would lead to another problem - the loading of the media file would be terribly time-consuming.

Anyone awares of this and has solution for it? Thanks in advance.

P.S. My OS is Windows 7 SP1 x86.
Last edited by zcc911 on Wed May 03, 2017 8:10 am, edited 1 time in total.
zcc911
Comic Sans MS
Comic Sans MS
 
Posts: 3
Joined: Sat Apr 29, 2017 10:36 am

Re: All Hotkeys/Shortcuts unavailable after Saving

Unread postby jfs » Tue May 02, 2017 7:47 pm

I've never heard of this before. It mostly sounds like the focus moves to something unexpected when you save. Do the hotkeys stay dead even after clicking once inside the audio display?
Do not PM me asking for help with Aegisub, Automation, karaoke or anything like that, I won't reply.
Ask your questions in the public forums. Use the Search function, somebody probably asked the same question before.
All rights reserved to call you insults if you ask poorly thought out or redundant questions.
Experimenting is free and is a great way to learn things.
User avatar
jfs
Developer
 
Posts: 2981
Joined: Mon Dec 19, 2005 8:18 pm
Location: Denmark

Re: All Hotkeys/Shortcuts unavailable after Saving

Unread postby zcc911 » Wed May 03, 2017 5:45 am

jfs wrote:I've never heard of this before. It mostly sounds like the focus moves to something unexpected when you save. Do the hotkeys stay dead even after clicking once inside the audio display?

TBH, I'm not 100% sure about what had happened. But it always took place after I had my work saved, and generally when I typed "Shift+Enter" but the Aegisub returned with nothing so I have to type "\" and "N" instead, until then would I realized the ineffective situation. It's also hard for me to predict it, given that it was not always occurred at/after the first save action, in other words it's random to me.

Once the hotkeys are unavailable, they will stay in disabled status until I restart the software or, click inside the audio display, which means the starting or ending timestamp of one single subtitle would be actually edited. However, if I move my mouse cursor elsewhere, and click afterwards (for instance, select a subtitle in the "Subtitles Grid"), then all hotkeys turn dead again.

I'll be appreciate if you can solve this.
zcc911
Comic Sans MS
Comic Sans MS
 
Posts: 3
Joined: Sat Apr 29, 2017 10:36 am

Re: All Hotkeys/Shortcuts unavailable after Saving

Unread postby zcc911 » Tue May 09, 2017 7:12 am

Here is my Aegisub's log when all-hotkeys-disabled issue happened: https://pastebin.com/MHnsM77j

Anything looks weird?
zcc911
Comic Sans MS
Comic Sans MS
 
Posts: 3
Joined: Sat Apr 29, 2017 10:36 am

Re: All Hotkeys/Shortcuts unavailable after Saving

Unread postby jfs » Tue May 09, 2017 4:09 pm

At line 38 it shows a file save event, I assume that's when you had the problem begin in that session?

As far as I can tell nothing changes between before and after. Especially notice line 40 and 41 together, it registers the S key being pressed and then logs that audio playback begins. That's equivalent to line 4 and 5, before the save event.
Do not PM me asking for help with Aegisub, Automation, karaoke or anything like that, I won't reply.
Ask your questions in the public forums. Use the Search function, somebody probably asked the same question before.
All rights reserved to call you insults if you ask poorly thought out or redundant questions.
Experimenting is free and is a great way to learn things.
User avatar
jfs
Developer
 
Posts: 2981
Joined: Mon Dec 19, 2005 8:18 pm
Location: Denmark


Return to Aegisub Help

Who is online

Users browsing this forum: trtlsxvh72 and 3 guests