Volume and zoom cursors missing

Don't know how to do something? Having issues running the program? Please post here.

Volume and zoom cursors missing

Unread postby annapm » Wed Nov 16, 2016 2:10 pm

Hi there,

I am unable to zoom vertically/horizontally or set the volume in the software as the cursors are missing. Everything was fine the first few times I used it - now impossible to subtitle as audio unclear when it's zoomed it vertically. Any idea what it's due to and how to change it?

Hope you can help!

Cheers,
Anna
Attachments
Screen Shot 2016-11-16 at 14.08.52.png
annapm
Comic Sans MS
Comic Sans MS
 
Posts: 1
Joined: Wed Nov 16, 2016 2:06 pm

Re: Volume and zoom cursors missing

Unread postby dokool » Thu Nov 24, 2016 1:35 am

Having the same issue as well! Help!
dokool
{\b1}
{\b1}
 
Posts: 6
Joined: Thu Nov 24, 2016 1:33 am

Re: Volume and zoom cursors missing

Unread postby kittynt15 » Thu Dec 08, 2016 3:39 pm

I'm having the same problem as well!! :((((
Please help :((((

Image
kittynt15
Comic Sans MS
Comic Sans MS
 
Posts: 1
Joined: Thu Dec 08, 2016 3:33 pm

Re: Volume and zoom cursors missing

Unread postby jfs » Thu Dec 08, 2016 5:16 pm

Yes it seems to be a bug.

No, we do not have a fix. Posting about it will likely not get a fix produced faster either. The fact is that everyone who's "on the project" is too busy with a regular job to work on Aegisub.

There is a possibility the problem may actually be an incompatibility between wxWidgets and recent macOS versions, and that simply rebuilding the current Aegisub code with a newer wxWidgets (where the bug is hopefully fixed) would rid the problem. I did read the relevant code in Aegisub for these sliders a few days ago, and I don't see anything obviously problematic, apart from some of them being set to have inverted value scale.

If anyone has a Mac, can reproduce the bug with the Aegisub version available for download, and knows how to set up a build environment for Aegisub on macOS, a test of whether a newer wxWidgets version solves the problem would be appreciated.
Do not PM me asking for help with Aegisub, Automation, karaoke or anything like that, I won't reply.
Ask your questions in the public forums. Use the Search function, somebody probably asked the same question before.
All rights reserved to call you insults if you ask poorly thought out or redundant questions.
Experimenting is free and is a great way to learn things.
User avatar
jfs
Developer
 
Posts: 2981
Joined: Mon Dec 19, 2005 8:18 pm
Location: Denmark

Re: Volume and zoom cursors missing

Unread postby n3st » Sun Feb 12, 2017 7:22 pm

Hello, I would like help with same problem here. Problem is that once you touch volume pitch it will irreversibly change your audio. I am willing to pay for the fix. Or alternatively can someone recommend another hardcoded subbtitle creating software ? Thank you
n3st
Comic Sans MS
Comic Sans MS
 
Posts: 2
Joined: Sun Feb 12, 2017 6:12 pm

Re: Volume and zoom cursors missing

Unread postby dokool » Wed Feb 22, 2017 4:25 am

Second the request for a good alternative... lots of dodgy-looking stuff in the App Store. Shame to see such great software be rendered ineffective for so many of us.
dokool
{\b1}
{\b1}
 
Posts: 6
Joined: Thu Nov 24, 2016 1:33 am

Re: Volume and zoom cursors missing

Unread postby jasonfilmaker » Fri Feb 24, 2017 9:22 pm

I am having the same issue with my software. It is making the subtitling process extremely difficult if not impossible. Does anyone know other alternative free software out there? I really need help!
jasonfilmaker
Comic Sans MS
Comic Sans MS
 
Posts: 1
Joined: Fri Feb 24, 2017 9:17 pm

Re: Volume and zoom cursors missing

Unread postby n3st » Sun Mar 05, 2017 8:08 am

Please help ... make the fix ... I will donate
n3st
Comic Sans MS
Comic Sans MS
 
Posts: 2
Joined: Sun Feb 12, 2017 6:12 pm

Re: Volume and zoom cursors missing

Unread postby jfs » Sun Mar 05, 2017 6:19 pm

I've gotten access to a machine with macOS now, and will look into the problem.
Do not PM me asking for help with Aegisub, Automation, karaoke or anything like that, I won't reply.
Ask your questions in the public forums. Use the Search function, somebody probably asked the same question before.
All rights reserved to call you insults if you ask poorly thought out or redundant questions.
Experimenting is free and is a great way to learn things.
User avatar
jfs
Developer
 
Posts: 2981
Joined: Mon Dec 19, 2005 8:18 pm
Location: Denmark

Re: Volume and zoom cursors missing

Unread postby jfs » Sun Mar 05, 2017 7:48 pm

Well, I've confirmed that the problem seems to be with wxWidgets not creating the vertical slider controls correctly, but creating horizontal ones instead. So the sliders have just one pixel of travel left to right, instead of the 200 or so up-down.

Going to attempt a fix now.
Do not PM me asking for help with Aegisub, Automation, karaoke or anything like that, I won't reply.
Ask your questions in the public forums. Use the Search function, somebody probably asked the same question before.
All rights reserved to call you insults if you ask poorly thought out or redundant questions.
Experimenting is free and is a great way to learn things.
User avatar
jfs
Developer
 
Posts: 2981
Joined: Mon Dec 19, 2005 8:18 pm
Location: Denmark

Re: Volume and zoom cursors missing

Unread postby dokool » Sat Mar 18, 2017 4:34 am

Is there any update on this?
dokool
{\b1}
{\b1}
 
Posts: 6
Joined: Thu Nov 24, 2016 1:33 am

Re: Volume and zoom cursors missing

Unread postby jfs » Sat Mar 18, 2017 7:04 am

No. It turns out that getting a correctly functioning build is difficult. In the builds I've made with the fix for the slider bug, there is a new bug where Aegisub crashes as soon as you begin typing in the subtitle edit box, and I haven't been able to debug that so far.
Do not PM me asking for help with Aegisub, Automation, karaoke or anything like that, I won't reply.
Ask your questions in the public forums. Use the Search function, somebody probably asked the same question before.
All rights reserved to call you insults if you ask poorly thought out or redundant questions.
Experimenting is free and is a great way to learn things.
User avatar
jfs
Developer
 
Posts: 2981
Joined: Mon Dec 19, 2005 8:18 pm
Location: Denmark

Re: Volume and zoom cursors missing

Unread postby razvan.ilinca » Wed Mar 22, 2017 4:07 pm

After I've touched these sliders, I've screwed the whole workflow. I've managed to uninstall aegisub with appcleaner, reinstall it and everything is back to normal. Sliders still not working but at least the zoom setting is fine.
razvan.ilinca
Comic Sans MS
Comic Sans MS
 
Posts: 1
Joined: Wed Mar 22, 2017 4:04 pm

Re: Volume and zoom cursors missing

Unread postby ∫xdxdy » Mon Mar 27, 2017 2:03 pm

jfs wrote:Well, I've confirmed that the problem seems to be with wxWidgets not creating the vertical slider controls correctly, but creating horizontal ones instead. So the sliders have just one pixel of travel left to right, instead of the 200 or so up-down.

Going to attempt a fix now.


I have seen this problem last year, And i choose to edit the config.json in Application Support, it works. But this is inconvenie.
∫xdxdy
Comic Sans MS
Comic Sans MS
 
Posts: 3
Joined: Mon Mar 27, 2017 1:59 pm

Re: Volume and zoom cursors missing

Unread postby dokool » Thu Mar 30, 2017 4:11 am

∫xdxdy wrote:
jfs wrote:Well, I've confirmed that the problem seems to be with wxWidgets not creating the vertical slider controls correctly, but creating horizontal ones instead. So the sliders have just one pixel of travel left to right, instead of the 200 or so up-down.

Going to attempt a fix now.


I have seen this problem last year, And i choose to edit the config.json in Application Support, it works. But this is inconvenie.


How exactly do you do this? I mean we need a fix but if there's a way to make it useable in the meantime...
dokool
{\b1}
{\b1}
 
Posts: 6
Joined: Thu Nov 24, 2016 1:33 am

Next

Return to Aegisub Help

Who is online

Users browsing this forum: No registered users and 1 guest